Issue Connecting with NEA
Incident Report for Porichoy
Resolved
This incident has been resolved.
Posted May 11, 2020 - 19:07 GMT+06:00
Update
The issue has been resolved
Posted May 11, 2020 - 19:05 GMT+06:00
Update
Investigation is being continued
Posted May 11, 2020 - 12:57 GMT+06:00
Investigating
The issue is being investigated
Posted May 11, 2020 - 08:45 GMT+06:00
This incident affected: NID Verification Service.